Lync 2010 installed on my new Samsung just fine, however when I try to login with my @microsoft.com credentials it gives me the following error message:

"This version of Lync has been blocked by your system administrator.  Please check for updates or contact your support team."

Does Lync 2010 not work on an Android phone with microsoft corpnet creds?

1 Comment

  1. Nick says:

    I have the same issue, lync2010 Samgsung Galaxy SIII, and same message, no fix as of yet. I’ve enabled every version on the admin site, No fix as of yet. How about you?

Leave a Reply